summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-07-11 17:04:56 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-07-11 22:24:33 +0200
commit66413378e8eb68ebcfeb1e2f4154a4443dfa21ca (patch)
tree5ceb8db1aded7181bf11eaf4641022b264501d14 /gnu
parente73ed2a1ecd4ad55fe4769bf3ad65d0a161881c6 (diff)
downloadguix-patches-66413378e8eb68ebcfeb1e2f4154a4443dfa21ca.tar
guix-patches-66413378e8eb68ebcfeb1e2f4154a4443dfa21ca.tar.gz
gnu: Add ghc-xdg-basedir.
* gnu/packages/haskell.scm (ghc-xdg-basedir): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ab8ed235bc..8d2dcba208 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9703,4 +9703,23 @@ serialization code.")
disk space usage.")
(license license:bsd-3)))
+(define-public ghc-xdg-basedir
+ (package
+ (name "ghc-xdg-basedir")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/xdg-basedir/"
+ "xdg-basedir-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0azlzaxp2dn4l1nr7shsxah2magk1szf6fx0mv75az00qsjw6qg4"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/willdonnelly/xdg-basedir")
+ (synopsis "XDG Base Directory library for Haskell")
+ (description "This package provides a library implementing the XDG Base Directory spec.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here