summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-07-20 11:29:57 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-07-21 13:36:07 +0200
commit18a02fe7ca0c7be77d40e9953f7b07685cabd80d (patch)
treefb545770c3712f4630d7095d3590c8b746d73602 /gnu
parent117988b7ca1d186873a86ae2cb9c1cba7f247c1d (diff)
downloadguix-patches-18a02fe7ca0c7be77d40e9953f7b07685cabd80d.tar
guix-patches-18a02fe7ca0c7be77d40e9953f7b07685cabd80d.tar.gz
gnu: Add tombo.
* gnu/packages/bioinformatics.scm (tombo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d9ff16e91e..e418b2cefd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14560,3 +14560,36 @@ quantifying single-cell chromatin data, computing per-cell quality control
metrics, dimension reduction and normalization, visualization, and DNA
sequence motif analysis.")
(license license:expat))))
+
+(define-public tombo
+ (package
+ (name "tombo")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ont-tombo" version))
+ (sha256
+ (base32
+ "1023hadgcsgi53kz53ql45207hfizf9sw57z0qij3ay1bx68zbpm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-nose2" ,python-nose2)))
+ ;; The package mainly consists of a command-line tool, but also has a
+ ;; Python-API. Thus these must be propagated.
+ (propagated-inputs
+ `(("python-future" ,python-future)
+ ("python-h5py" ,python-h5py)
+ ("python-mappy" ,python-mappy)
+ ("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)
+ ("python-tqdm" ,python-tqdm)
+ ("python-rpy2" ,python-rpy2)))
+ (home-page "https://github.com/nanoporetech/tombo")
+ (synopsis "Analysis of raw nanopore sequencing data")
+ (description "Tombo is a suite of tools primarily for the identification of
+modified nucleotides from nanopore sequencing data. Tombo also provides tools
+for the analysis and visualization of raw nanopore signal.")
+ ;; Some parts may be BSD-3-licensed.
+ (license license:mpl2.0)))