summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-07-20 11:50:31 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-07-21 13:36:08 +0200
commit086c6800cfeb3db88bcd33badf5a6683ba4ce9db (patch)
treef4ddd458f7da72842d9950bf6ab9693f3e984f66 /gnu
parent18a02fe7ca0c7be77d40e9953f7b07685cabd80d (diff)
downloadguix-patches-086c6800cfeb3db88bcd33badf5a6683ba4ce9db.tar
guix-patches-086c6800cfeb3db88bcd33badf5a6683ba4ce9db.tar.gz
gnu: checkm: Rename and update to 1.1.3.
Renamed from python2-checkm-genome to checkm to better reflect its status as standalone-application and support for Python 3. * gnu/packages/bioinformatics.scm (python2-checkm-genome): Redirect to… (checkm): …here and update to 1.1.3. [propagated-inputs]: Move to inputs. [inputs]: Use Python 3 dependencies. [home-page]: Point to real home-page.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 20 insertions, 13 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e418b2cefd..8aa21c4fd6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13061,28 +13061,32 @@ downstream analysis.")
("taxtastic" ,taxtastic)))
(synopsis "Pplacer Python scripts")))
-(define-public python2-checkm-genome
+(define-public checkm
(package
- (name "python2-checkm-genome")
- (version "1.0.13")
+ (name "checkm")
+ (version "1.1.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "checkm-genome" version))
(sha256
(base32
- "0bm8gpxjmzxsxxl8lzwqhgx8g1dlnmp6znz7wv3hgb0gdjbf9dzz"))))
+ "0i2nnki639hgjag17wlva2x0ymn37b4krqsf6akxddykhfbkdnkz"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f)) ; some tests are interactive
- (propagated-inputs
- `(("python-dendropy" ,python2-dendropy)
- ("python-matplotlib" ,python2-matplotlib)
- ("python-numpy" ,python2-numpy)
- ("python-pysam" ,python2-pysam)
- ("python-scipy" ,python2-scipy)))
- (home-page "https://pypi.org/project/Checkm/")
+ `(#:tests? #f ; Some tests fail for unknown reasons.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (inputs
+ `(("python-dendropy" ,python-dendropy)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-numpy" ,python-numpy)
+ ("python-pysam" ,python-pysam)
+ ("python-scipy" ,python-scipy)))
+ (home-page "https://ecogenomics.github.io/CheckM/")
(synopsis "Assess the quality of putative genome bins")
(description
"CheckM provides a set of tools for assessing the quality of genomes
@@ -13097,6 +13101,9 @@ on marker set compatibility, similarity in genomic characteristics, and
proximity within a reference genome.")
(license license:gpl3+)))
+(define-public python2-checkm-genome
+ (deprecated-package "python2-checkm-genome" checkm))
+
(define-public umi-tools
(package
(name "umi-tools")