summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-23 17:31:03 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:17 +0100
commitd547ce5e70b0bbd1ea33471c7d0029f5ae3e49f5 (patch)
treee8acfd6f8dbf6628149ec413330caae72bba7b7d /gnu
parente05c37da4aaa8c0e01cc9e1b6a5f8be45280659a (diff)
downloadguix-patches-d547ce5e70b0bbd1ea33471c7d0029f5ae3e49f5.tar
guix-patches-d547ce5e70b0bbd1ea33471c7d0029f5ae3e49f5.tar.gz
gnu: Add topGO.
* gnu/packages/bioinformatics.scm (r-topgo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f2a15b4674..31326f2752 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3807,6 +3807,35 @@ extracting the desired features in a convenient format.")
information about the latest version of the Gene Ontologies.")
(license license:artistic2.0)))
+(define-public r-topgo
+ (package
+ (name "r-topgo")
+ (version "2.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "topGO" version))
+ (sha256
+ (base32
+ "029j9nb39b8l9xlzsp83pmjr8ap247aia387yzaa1yyw8klapdaf"))))
+ (properties
+ `((upstream-name . "topGO")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-go-db" ,r-go-db)
+ ("r-sparsem" ,r-sparsem)))
+ (home-page "http://bioconductor.org/packages/topGO")
+ (synopsis "Enrichment analysis for gene ontology")
+ (description
+ "The topGO package provides tools for testing @dfn{gene ontology} (GO)
+terms while accounting for the topology of the GO graph. Different test
+statistics and different methods for eliminating local similarities and
+dependencies between GO terms can be implemented and applied.")
+ ;; Any version of the LGPL applies.
+ (license license:lgpl2.1+)))
+
(define-public r-qtl
(package
(name "r-qtl")