summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 17:07:49 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:19:56 +0200
commitd0b3bb9df7dd04449d7d9a4d0e7f4b67b255a3e6 (patch)
tree95696f88ec4b928801a147a6b6dee0ef1d65f46c /gnu
parent3cd509bf66dc322d89dfcf8e1608b53b859206a0 (diff)
downloadguix-patches-d0b3bb9df7dd04449d7d9a4d0e7f4b67b255a3e6.tar
guix-patches-d0b3bb9df7dd04449d7d9a4d0e7f4b67b255a3e6.tar.gz
gnu: python-watchgod: Respect "--without-tests".
* gnu/packages/python-xyz.scm (python-watchgod)[arguments]<#:phases>{check}: Respect #:tests?. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a44043635..2bb33dbd63 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23348,8 +23348,9 @@ but portable.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-docutils" ,python-docutils)