summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-08 17:27:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:50 +0200
commitc7cfe540181f823e20c8b8b4e23b193dcb319856 (patch)
treed68283ff45097861e2aa7d07b5a415fa671cbb78 /gnu
parentef3d60fc7631ae117be1fd7096f0a568adb01c62 (diff)
downloadguix-patches-c7cfe540181f823e20c8b8b4e23b193dcb319856.tar
guix-patches-c7cfe540181f823e20c8b8b4e23b193dcb319856.tar.gz
gnu: python-seaborn: 'check' phase honors #:tests?.
* gnu/packages/python-xyz.scm (python-seaborn)[arguments]: Change 'check' phase to honor #:tests?.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2bb33dbd63..193c86ac48 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8819,7 +8819,10 @@ SVG, EPS, PNG and terminal output.")
(system (format #f "~a/bin/Xvfb :1 &" xorg-server))
(setenv "DISPLAY" ":1")
#t)))
- (replace 'check (lambda _ (invoke "pytest" "seaborn") #t)))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "seaborn")))))))
(propagated-inputs
`(("python-pandas" ,python-pandas)
("python-matplotlib" ,python-matplotlib)