summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-30 18:54:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-10-30 18:54:41 +0100
commita8dd960ac0c68957dac281812f0d16f1295a6eaa (patch)
treef738115f8a5afca4a53d5e7d017ff06c4d195913 /gnu
parentf34ef3317e6ee87c28e8832d15e59afe4f391f03 (diff)
downloadguix-patches-a8dd960ac0c68957dac281812f0d16f1295a6eaa.tar
guix-patches-a8dd960ac0c68957dac281812f0d16f1295a6eaa.tar.gz
gnu: python-joblib: Disable failing tests.
* gnu/packages/python.scm (python-joblib)[arguments]: Add phase to disable failing tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c27137c540..9c7320f41e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2757,6 +2757,25 @@ logic-free templating system Mustache.")
(base32
"0787k919zlfmgymprz5bzv0v1df5bbirlf3awrghmjgvkrd9dci9"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-tests
+ (lambda _
+ ;; This numpydoc tests fails for unknown reasons
+ (delete-file "doc/sphinxext/numpydoc/tests/test_docscrape.py")
+ ;; This numpydoc test depends on matplotlib, which is not a
+ ;; required input.
+ (delete-file "doc/sphinxext/numpydoc/tests/test_plot_directive.py")
+ ;; These tests fail to execute sys.executable
+ (substitute* "joblib/test/test_parallel.py"
+ (("import nose" line)
+ (string-append "from nose.plugins.skip import SkipTest\n" line))
+ (("def test_nested_parallel_warnings" line)
+ (string-append "@SkipTest\n" line))
+ (("def test_parallel_with_interactively_defined_functions" line)
+ (string-append "@SkipTest\n" line)))
+ #t)))))
(native-inputs
`(("python-setuptools" ,python-setuptools)
("python-nose" ,python-nose)