summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-23 17:29:08 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:17 +0100
commita63efbb453c05cd6f9b0831582fa741f72be3755 (patch)
treea308a3b7f15949d09c719fa657822c9b83690e8c /gnu
parent9c94b53b5b5cce8d069e4566b69e86876d451023 (diff)
downloadguix-patches-a63efbb453c05cd6f9b0831582fa741f72be3755.tar
guix-patches-a63efbb453c05cd6f9b0831582fa741f72be3755.tar.gz
gnu: Add R.cache.
* gnu/packages/statistics.scm (r-r-cache): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 76d54f8483..96253595fd 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1806,3 +1806,29 @@ maintenance for package developers.")
developing R packages.")
(license license:lgpl2.1+)))
+(define-public r-r-cache
+ (package
+ (name "r-r-cache")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "R.cache" version))
+ (sha256
+ (base32
+ "006x52w9r8phw5hgqmyp0bz8z42vn8p5yibibnzi1sfa1xlw8iyx"))))
+ (properties `((upstream-name . "R.cache")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-r-methodss3" ,r-r-methodss3)
+ ("r-r-oo" ,r-r-oo)
+ ("r-r-utils" ,r-r-utils)))
+ (home-page "https://github.com/HenrikBengtsson/R.cache")
+ (synopsis "Light-weight caching of objects and results")
+ (description
+ "This package provides methods for caching or memoization of objects and
+results. With this package, any R object can be cached in a key-value storage
+where the key can be an arbitrary set of R objects. The cache memory is
+persistent (on the file system).")
+ (license license:lgpl2.1+)))
+