summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:34:44 +0200
commit90bbab5cff337c522003adde870f127179f25f3d (patch)
tree1a2c236d5af0730e81f7f5c4bd60781a55dbc87e /gnu
parentf78ff75b411fe2d07b18529db6fb1da231bcc4cd (diff)
downloadguix-patches-90bbab5cff337c522003adde870f127179f25f3d.tar
guix-patches-90bbab5cff337c522003adde870f127179f25f3d.tar.gz
gnu: r-topgo: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-topgo): Move from here... * gnu/packages/bioconductor.scm (r-topgo): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm33
-rw-r--r--gnu/packages/bioinformatics.scm33
2 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7278bb486b..a0f5222937 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2873,6 +2873,39 @@ experimental designs is facilitated by a consistently implemented sample
annotation infrastructure.")
(license license:artistic2.0)))
+(define-public r-topgo
+ (package
+ (name "r-topgo")
+ (version "2.42.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "topGO" version))
+ (sha256
+ (base32
+ "0vr3l9gvd3dhy446k3fkj6rm7z1abxi56rbnrs64297yzxaz1ngl"))))
+ (properties
+ `((upstream-name . "topGO")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-dbi" ,r-dbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-go-db" ,r-go-db)
+ ("r-graph" ,r-graph)
+ ("r-lattice" ,r-lattice)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-sparsem" ,r-sparsem)))
+ (home-page "https://bioconductor.org/packages/topGO")
+ (synopsis "Enrichment analysis for gene ontology")
+ (description
+ "The topGO package provides tools for testing @dfn{gene ontology} (GO)
+terms while accounting for the topology of the GO graph. Different test
+statistics and different methods for eliminating local similarities and
+dependencies between GO terms can be implemented and applied.")
+ ;; Any version of the LGPL applies.
+ (license license:lgpl2.1+)))
+
(define-public r-variantannotation
(package
(name "r-variantannotation")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fe81959ef0..e78769b1d3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7976,39 +7976,6 @@ including VCF header and contents in RDF and JSON.")
information about the latest version of the Gene Ontologies.")
(license license:artistic2.0)))
-(define-public r-topgo
- (package
- (name "r-topgo")
- (version "2.42.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "topGO" version))
- (sha256
- (base32
- "0vr3l9gvd3dhy446k3fkj6rm7z1abxi56rbnrs64297yzxaz1ngl"))))
- (properties
- `((upstream-name . "topGO")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)
- ("r-dbi" ,r-dbi)
- ("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-go-db" ,r-go-db)
- ("r-graph" ,r-graph)
- ("r-lattice" ,r-lattice)
- ("r-matrixstats" ,r-matrixstats)
- ("r-sparsem" ,r-sparsem)))
- (home-page "https://bioconductor.org/packages/topGO")
- (synopsis "Enrichment analysis for gene ontology")
- (description
- "The topGO package provides tools for testing @dfn{gene ontology} (GO)
-terms while accounting for the topology of the GO graph. Different test
-statistics and different methods for eliminating local similarities and
-dependencies between GO terms can be implemented and applied.")
- ;; Any version of the LGPL applies.
- (license license:lgpl2.1+)))
-
(define-public r-bsgenome
(package
(name "r-bsgenome")