summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-04-15 15:21:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-04-17 12:59:59 +0200
commit82bead7537d395507071489979576bfc0be44f73 (patch)
tree0c0e6403c784bb905039e4113574557a4f28a398 /gnu
parentbfb4004d3463a6857ff0aaeb9513a55c262970f0 (diff)
downloadguix-patches-82bead7537d395507071489979576bfc0be44f73.tar
guix-patches-82bead7537d395507071489979576bfc0be44f73.tar.gz
gnu: Add emacs-ergoemacs-mode.
* gnu/packages/emacs.scm (emacs-ergoemacs-mode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 05115bdabe..d94d92f80a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7567,6 +7567,32 @@ Anzu.zim.")
used with SGML-like languages: XML, HTML, XHTML, XSL, etc.")
(license license:gpl3+)))
+(define-public emacs-ergoemacs-mode
+ (let ((commit "3ce23bba3cb50562693860f87f3528c471d603ba")
+ (revision "1"))
+ (package
+ (name "emacs-ergoemacs-mode")
+ (version (git-version "5.16.10.12" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ergoemacs/ergoemacs-mode.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1s3b9bridl78hh1mxmdk9nqlmqhibbaxk0a1cixmsf23s06w8w6l"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-undo-tree" ,emacs-undo-tree)))
+ (home-page "https://ergoemacs.github.io/")
+ (synopsis "Emacs mode based on common modern interface and ergonomics")
+ (description
+ "This package provides an efficient Emacs keybinding set based on
+statistics of command frequency, and supports common shortcuts for open,
+close, copy, cut, paste, undo, redo.")
+ (license license:gpl3+))))
+
(define-public emacs-password-store
(package
(name "emacs-password-store")