summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-02-25 07:07:06 -0600
committerLeo Famulari <leo@famulari.name>2016-02-25 16:36:10 -0500
commit66d59111e3a6deeddd6b2e4f96a6c5440785532f (patch)
tree89c1dcd24caa58298642943d04a6f433479c33a2 /gnu
parent735e84c7bd10af6859d4a164a68595d8e67b826d (diff)
downloadguix-patches-66d59111e3a6deeddd6b2e4f96a6c5440785532f.tar
guix-patches-66d59111e3a6deeddd6b2e4f96a6c5440785532f.tar.gz
gnu: Add dconf-editor.
* gnu/packages/gnome.scm (dconf-editor): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d68633e83d..578b43121b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4742,6 +4742,36 @@ screen, a window or a user defined area of the screen, with optional
beautifying border effects.")
(license license:gpl2+)))
+(define-public dconf-editor
+ (package
+ (name "dconf-editor")
+ (version "3.18.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0xdwi7g1xdmgrc9m8ii62fp2zj114gsfpmgazlnhrcmmfi97z5d7"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dconf" ,dconf)
+ ("gtk+" ,gtk+)
+ ("libxml2" ,libxml2)))
+ (home-page "https://git.gnome.org/browse/dconf-editor")
+ (synopsis "Graphical editor for GNOME's dconf configuration system")
+ (description
+ "Dconf-editor is a graphical tool for browsing and editing the dconf
+configuration system for GNOME. It allows users to configure desktop
+software that do not provide their own configuration interface.")
+ (license license:lgpl2.1+)))
+
(define-public gnome
(package
(name "gnome")