summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHugo Lecomte <hugo.lecomte@inria.fr>2021-07-05 09:29:24 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:50 +0200
commit4204af996729547a14fd17ce205896ccbb6761c3 (patch)
tree5ed454f2cb35c8817365f6a0fc22c096df6f9184 /gnu
parent9bfc4a81870b83dc8bb066d73d0cdd48e74e1aa3 (diff)
downloadguix-patches-4204af996729547a14fd17ce205896ccbb6761c3.tar
guix-patches-4204af996729547a14fd17ce205896ccbb6761c3.tar.gz
gnu: Add python-escapism.
* gnu/packages/python-xyz.scm (python-escapism): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 181729b2bb..6df3012b7e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -104,6 +104,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25963,3 +25964,23 @@ is the cythonized version of @code{fractions.Fraction}.")
"@code{pathvalidate} is a Python library to sanitize/validate strings
representing paths or filenames.")
(license license:expat)))
+
+(define-public python-escapism
+ (package
+ (name "python-escapism")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "escapism" version))
+ (sha256
+ (base32
+ "1v74243wifcwhj5zkdiispxc9kb1xvnfzilg8bq308pjnkgnn9bk"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/minrk/escapism")
+ (synopsis "Simple, generic library for escaping strings")
+ (description
+ "This Python library provides a programming interface to, given a set of
+safe characters and an escape character, escape safe strings and unescape the
+result.")
+ (license license:expat)))