summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-18 21:20:38 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-25 15:27:48 +0100
commit37f5caec4e886cc19605f6a249d65d13f05994b2 (patch)
tree1436f576a674d622ee00ea6f05a0c7d6892c301f /gnu
parentc9505f3ffa9597c6d765d871d800e56fb45dd7ef (diff)
downloadguix-patches-37f5caec4e886cc19605f6a249d65d13f05994b2.tar
guix-patches-37f5caec4e886cc19605f6a249d65d13f05994b2.tar.gz
gnu: Add sysfsutils.
* gnu/packages/linux.scm (sysfsutils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1558d09031..935a1728f4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1913,3 +1913,27 @@ during the system boot, and will run as a background process. When an ACPI
event is received from the kernel, acpid will examine the list of rules
specified in /etc/acpi/events and execute the rules that match the event.")
(license gpl2+)))
+
+(define-public sysfsutils
+ (package
+ (name "sysfsutils")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "mirror://sourceforge/linux-diag/sysfsutils/" version "/sysfsutils-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "12i0ip11xbfcjzxz4r10cvz7mbzgq1hfcdn97w6zz7sm3wndwrg8"))))
+ (build-system gnu-build-system)
+ (home-page "http://linux-diag.sourceforge.net/Sysfsutils.html")
+ (synopsis "System utilities based on Linux sysfs")
+ (description
+ "These are a set of utilites built upon sysfs, a virtual filesystem in
+Linux kernel versions 2.5+ that exposes a system's device tree. The package
+also contains the libsysfs library.")
+ ;; The library is under lgpl2.1+ (all files say "or any later version").
+ ;; The rest is mostly gpl2, with a few files indicating gpl2+.
+ (license (list gpl2 gpl2+ lgpl2.1+))))