summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 03:41:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 11:19:56 +0100
commit162d9c871034e59b36171f04a86805b575628bfb (patch)
treed0f20266919098af39e8118b3f8ce68ed542d467 /gnu
parent46c8cb6140732b46eab834686e053c15a16d92d1 (diff)
downloadguix-patches-162d9c871034e59b36171f04a86805b575628bfb.tar
guix-patches-162d9c871034e59b36171f04a86805b575628bfb.tar.gz
gnu: cpuid: Update to 20211031.
* gnu/packages/linux.scm (cpuid): Update to 20211031. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index afc8b919b2..a53420993a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7157,14 +7157,14 @@ available in the kernel Linux.")
(define-public cpuid
(package
(name "cpuid")
- (version "20201006")
+ (version "20211031")
(source (origin
(method url-fetch)
(uri (string-append "http://www.etallen.com/cpuid/cpuid-"
version ".src.tar.gz"))
(sha256
(base32
- "19jnkh57f979b78ak5mpxmdvnkgc33r55cw9shgd2hc380b3zi8k"))))
+ "13sxb2ar4gypiv0l87lr7hf3qjccwgsg1r92adv9jvrfxcv36pbn"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -7179,8 +7179,7 @@ available in the kernel Linux.")
;; Make the compressed manpages writable so that the
;; reset-gzip-timestamps phase does not error out.
(substitute* "Makefile"
- (("-m 444") "-m 644"))
- #t)))))
+ (("-m 444") "-m 644")))))))
(inputs `(("perl" ,perl)))
(supported-systems '("i686-linux" "x86_64-linux"))
(home-page "http://www.etallen.com/cpuid.html")