summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-26 12:15:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-26 12:15:06 +0200
commit0f7378d7f974a90493b4a1d5a50a39a821cd4916 (patch)
tree319dd2b195e361d5681688b1da5fad2534a01283 /gnu
parentce67853e0973c611e460812d08f90fed0747a94a (diff)
downloadguix-patches-0f7378d7f974a90493b4a1d5a50a39a821cd4916.tar
guix-patches-0f7378d7f974a90493b4a1d5a50a39a821cd4916.tar.gz
gnu: emacs-magit: Update to 2.90.1-6-7f486d4.
* gnu/packages/emacs-xyz.scm (emacs-magit): Update to 2.90.1-6-7f486d4.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a059e2d3e..33f81c1c66 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -473,19 +473,20 @@ libgit2 bindings for Emacs, intended to boost the performance of Magit.")
(define-public emacs-magit
;; There hasn't been an official release since 2018-11-16.
- (let ((commit "0746bf1bacfe896d3917ccc19c7fb9d95c18b1e9"))
+ (let ((commit "7f486d47fe7042edba8d9a855a4c2c301a30bc6b")
+ (revision "6"))
(package
(name "emacs-magit")
- (version (git-version "2.90.1" "5" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/magit/magit.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1sgdygr81s2qxq2ahf998hl89qrb0r2wbgnsiz3hdda1431p0wzg"))))
+ (version (git-version "2.90.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/magit.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05kyc5y5wa1p3h8j7mbgvfc4zcj998zi26lnnmksj9wnvahzxfms"))))
(build-system emacs-build-system)
(arguments
`(#:emacs ,emacs-no-x ;module support is required
@@ -550,11 +551,12 @@ libgit2 bindings for Emacs, intended to boost the performance of Magit.")
("emacs-with-editor" ,emacs-with-editor)))
(home-page "https://magit.vc/")
(synopsis "Emacs interface for the Git version control system")
- (description "With Magit, you can inspect and modify your Git
-repositories with Emacs. You can review and commit the changes you have made
-to the tracked files, for example, and you can browse the history of past
-changes. There is support for cherry picking, reverting, merging, rebasing,
-and other common Git operations.")
+ (description
+ "With Magit, you can inspect and modify your Git repositories
+with Emacs. You can review and commit the changes you have made to
+the tracked files, for example, and you can browse the history of past
+changes. There is support for cherry picking, reverting, merging,
+rebasing, and other common Git operations.")
(license license:gpl3+))))
(define-public emacs-magit-svn