summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 15:34:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 17:07:50 +0100
commit0df82727a6e2ac2389d8e94aa66a641687bf4039 (patch)
tree2da7042c895c93c9772b5ee81d0ee34eb8327f9f /gnu
parent97fd67edea951edd53d62250975edf93ed90c1a5 (diff)
downloadguix-patches-0df82727a6e2ac2389d8e94aa66a641687bf4039.tar
guix-patches-0df82727a6e2ac2389d8e94aa66a641687bf4039.tar.gz
gnu: ocaml-ppx-variants-conv: Update to 0.14.2.
* gnu/packages/ocaml.scm (ocaml-ppx-variants-conv): Update to 0.14.2. [origin]: Remove patch. * gnu/packages/patches/ocaml-ppx-variants-ppxlib-api-change.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ocaml.scm8
-rw-r--r--gnu/packages/patches/ocaml-ppx-variants-ppxlib-api-change.patch42
3 files changed, 2 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7cc06c8212..a8540f6e12 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1533,7 +1533,6 @@ dist_patch_DATA = \
%D%/packages/patches/ocaml-dose3-Fix-for-ocaml-4.06.patch \
%D%/packages/patches/ocaml-dose3-dont-make-printconf.patch \
%D%/packages/patches/ocaml-dose3-Install-mli-cmx-etc.patch \
- %D%/packages/patches/ocaml-ppx-variants-ppxlib-api-change.patch \
%D%/packages/patches/omake-fix-non-determinism.patch \
%D%/packages/patches/oneko-remove-nonfree-characters.patch \
%D%/packages/patches/onnx-optimizer-system-library.patch \
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b52c6803b3..3db79032c4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5465,21 +5465,17 @@ definitions.")
(define-public ocaml-ppx-variants-conv
(package
(name "ocaml-ppx-variants-conv")
- (version "0.14.1")
+ (version "0.14.2")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/janestreet/ppx_variants_conv")
(commit (string-append "v" version))))
- (patches
- (search-patches
- ;; Fix build when building with ocaml-ppxlib@0.23.0.
- "ocaml-ppx-variants-ppxlib-api-change.patch"))
(file-name (git-file-name name version))
(sha256
(base32
- "0q6a43zrwqzdz7aja0k44a2llyjjj5xzi2kigwhsnww3g0r5ig84"))))
+ "1p11fiz4m160hs0xzg4g9rxchp053sz3s3d1lyciqixad1xi47a4"))))
(build-system dune-build-system)
(propagated-inputs
`(("ocaml-base" ,ocaml-base)
diff --git a/gnu/packages/patches/ocaml-ppx-variants-ppxlib-api-change.patch b/gnu/packages/patches/ocaml-ppx-variants-ppxlib-api-change.patch
deleted file mode 100644
index b437bfb061..0000000000
--- a/gnu/packages/patches/ocaml-ppx-variants-ppxlib-api-change.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 6103f6fc56f978c847ba7c1f2d9f38ee93a5e337 Mon Sep 17 00:00:00 2001
-From: Sonja Heinze <sonjaleaheinze@gmail.com>
-Date: Tue, 9 Mar 2021 12:57:47 +0100
-Subject: [PATCH] Adapt to Ppxlib's API change
-
-Ppxlib is removing Lexer.keyword_table from the API in exchange for
-the more lightweight Keyword.is_keyword.
-
-Signed-off-by: Sonja Heinze <sonjaleaheinze@gmail.com>
----
-Patch from <https://github.com/janestreet/ppx_variants_conv/pull/9>.
-
- ppx_variants_conv.opam | 2 +-
- src/ppx_variants_conv.ml | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ppx_variants_conv.opam b/ppx_variants_conv.opam
-index 7e7148d..b56040f 100644
---- a/ppx_variants_conv.opam
-+++ b/ppx_variants_conv.opam
-@@ -15,7 +15,7 @@ depends: [
- "base" {>= "v0.14" & < "v0.15"}
- "variantslib" {>= "v0.14" & < "v0.15"}
- "dune" {>= "2.0.0"}
-- "ppxlib" {>= "0.14.0"}
-+ "ppxlib" {>= "0.23.0"}
- ]
- synopsis: "Generation of accessor and iteration functions for ocaml variant types"
- description: "
-diff --git a/src/ppx_variants_conv.ml b/src/ppx_variants_conv.ml
-index 8d60086..112fc78 100644
---- a/src/ppx_variants_conv.ml
-+++ b/src/ppx_variants_conv.ml
-@@ -66,7 +66,7 @@ end
-
- let variant_name_to_string v =
- let s = String.lowercase v in
-- if Caml.Hashtbl.mem Lexer.keyword_table s
-+ if Keyword.is_keyword s
- then s ^ "_"
- else s
-