summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 10:55:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:20 +0200
commitfac893fa7fbbe854aa3fa53ca399c52c9a59e11e (patch)
tree80fc0c36b301551e8528f9ad57f9dbc34c27c5f5 /gnu
parent9f120e9150ae51cf6274479e9b6441f09b6a93dc (diff)
downloadguix-patches-fac893fa7fbbe854aa3fa53ca399c52c9a59e11e.tar
guix-patches-fac893fa7fbbe854aa3fa53ca399c52c9a59e11e.tar.gz
gnu: Add r-zscorer.
* gnu/packages/cran.scm (r-zscorer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8499b2a44f..0dabbda66e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30453,3 +30453,30 @@ Bessel K function.")
variates and maximum likelihood estimates of the Zero-truncated Poisson
lognormal distribution and their mixture distribution.")
(license license:expat)))
+
+(define-public r-zscorer
+ (package
+ (name "r-zscorer")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "zscorer" version))
+ (sha256
+ (base32
+ "0aijhs0fyird5gq68x4dxchb02mxa7ijk10k9zjhngghxbjj7iqn"))))
+ (properties `((upstream-name . "zscorer")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-shiny" ,r-shiny)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/nutriverse/zscorer")
+ (synopsis "Child Anthropometry z-Score Calculator")
+ (description
+ "This package provides a tool for calculating z-scores and centiles for
+weight-for-age, length/height-for-age, weight-for-length/height, BMI-for-age,
+head circumference-for-age, age circumference-for-age, subscapular
+skinfold-for-age, triceps skinfold-for-age based on the WHO Child Growth
+Standards.")
+ (license license:agpl3+)))