summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-16 13:39:39 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-16 14:38:02 +0100
commite699eb3bccab17cd24ca57ce27e3544c9a8927fc (patch)
treeeff5ce25a7e07fed57804a08d937e6cc84296361 /gnu
parentf35976584cce09e3e857f75caa812daedc8cc07e (diff)
downloadguix-patches-e699eb3bccab17cd24ca57ce27e3544c9a8927fc.tar
guix-patches-e699eb3bccab17cd24ca57ce27e3544c9a8927fc.tar.gz
gnu: Add texlive-translator.
* gnu/packages/tex.scm (texlive-translator): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c174a3f80..ba959b8191 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8829,6 +8829,28 @@ are valid as arguments for the macros. The package may be used under
LaTeX and plain TeX.")
(license (license:fsf-free "file:/binhex.dtx"))))
+(define-public texlive-translator
+ (package
+ (inherit (simple-texlive-package
+ "texlive-translator"
+ (list "doc/latex/translator/"
+ "tex/latex/translator/")
+ (base32
+ "1pac03qghaw9q98skfrgzgk4wnz04pgizw59c4k5ydphw1vpsvcz")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/macros/latex/contrib/translator")
+ (synopsis "Easy translation of strings in LaTeX")
+ (description
+ "This LaTeX package provides a flexible mechanism for translating
+individual words into different languages. For example, it can be used to
+translate a word like \"figure\" into, say, the German word \"Abbildung\".
+Such a translation mechanism is useful when the author of some package would
+like to localize the package such that texts are correctly translated into the
+language preferred by the user. This package is not intended to be used to
+automatically translate more than a few words.")
+ (license (list license:lppl license:gpl1+))))
+
(define-public bibtool
(package
(name "bibtool")