summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-16 18:49:08 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-08 10:33:07 +0100
commitcecd572bd7027791cdb56c42b3657ea842cf5221 (patch)
tree91813e4d71852ddc0dc112304ed1e6c44809808c /gnu
parentcb09ac57b4ba1a3ebc641914c6c91a1054088a21 (diff)
downloadguix-patches-cecd572bd7027791cdb56c42b3657ea842cf5221.tar
guix-patches-cecd572bd7027791cdb56c42b3657ea842cf5221.tar.gz
gnu: Add rust-cmac-0.5.
* gnu/packages/crates-io.scm (rust-cmac-0.5): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f379c375de..721ad88419 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5863,6 +5863,31 @@ contains all syscalls and related types.")
license:asl2.0
license:zlib))))
+(define-public rust-cmac-0.5
+ (package
+ (name "rust-cmac")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cmac" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0wj2kd4lb5hb7dvxfad4hi8gklmbq8vvvcnzmmqgxr94fx7xxm3k"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-crypto-mac" ,rust-crypto-mac-0.10)
+ ("rust-dbl" ,rust-dbl-0.3))))
+ (home-page "https://docs.rs/cmac/")
+ (synopsis "Generic implementation of Cipher-based Message Authentication
+Code")
+ (description "This package provides a pure Rust implementation of the
+Cipher-based Message Authentication Code (CMAC).")
+ (license (list license:expat license:asl2.0)))) ; at your choice
+
(define-public rust-cmake-0.1
(package
(name "rust-cmake")