summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-11 13:53:59 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-11 15:39:19 +0000
commitb8c9f061e100949f081157eb4c9a7a2299ce9187 (patch)
treeb129a0c99147afc5e7dff9c74320f0f086193456 /gnu
parent4052310e91456530f0b5362f5895255e36d53055 (diff)
downloadguix-patches-b8c9f061e100949f081157eb4c9a7a2299ce9187.tar
guix-patches-b8c9f061e100949f081157eb4c9a7a2299ce9187.tar.gz
gnu: Add bioparser.
* gnu/packages/bioinformatics.scm (bioparser): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8139ce43de..ae3cf01c87 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1354,6 +1354,42 @@ relying on a complex dependency tree.")
used for storage and logging in bioinformatics tools.")
(license license:expat)))
+(define-public bioparser
+ (package
+ (name "bioparser")
+ (version "3.0.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rvaser/bioparser")
+ ;; Corresponds to tag 3.0.13
+ (commit "13341e6e0855c6b358ffcea6dad216e1009e1287")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0c5p2dl8jb12ci9f427jzrmmm9cgvc1k4fxsn2ggkfsin6r1r82i"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./bin/bioparser_test")))))))
+ (inputs
+ `(("biosoup" ,biosoup)))
+ (propagated-inputs
+ `(("zlib" ,zlib)))
+ (native-inputs
+ `(("googletest" ,googletest)))
+ (home-page "https://github.com/rvaser/bioparser")
+ (synopsis "C++ library for parsing several formats in bioinformatics")
+ (description "Bioparser is a C++ header only parsing library for several
+bioinformatics formats (FASTA/Q, MHAP/PAF/SAM), with support for zlib
+compressed files.")
+ (license license:expat)))
+
(define-public ciri-long
(package
(name "ciri-long")