summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:44:39 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:45:50 +0800
commitaac03800408393d98e6e3203a988bcfcf3c19256 (patch)
tree5381ebfe250360468eabe7e46f78d79f45efb231 /gnu
parent5c776d27060ef2c142bf9d39f40011cf7bdfc558 (diff)
downloadguix-patches-aac03800408393d98e6e3203a988bcfcf3c19256.tar
guix-patches-aac03800408393d98e6e3203a988bcfcf3c19256.tar.gz
gnu: Add thunar-volman.
* gnu/packages/xfce.scm (thunar-volman): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index de369c9fae..3332e870f8 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -386,3 +386,33 @@ like appearance, display, keyboard and mouse settings.")
"A modern file manager for graphical desktop, aiming to be easy-to-use and
fast.")
(license gpl2+)))
+
+(define-public thunar-volman
+ (package
+ (name "thunar-volman")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1sxw09fwyn5sr6ipxk7r8gqjyf41c2v7vkgl0l6mhy5mcb48f27z"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("exo" ,exo)
+ ("gudev" ,eudev)
+ ("libnotify" ,libnotify)
+ ("libxfce4ui" ,libxfce4ui)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Removable media manager for Thunar")
+ (description
+ "Thunar-volman is an extension for the Thunar File Manager, which enables
+automatic management of removable drives and media. For example, if
+thunar-volman is installed and configured properly, and you plug in your
+digitcal camera, it will automatically spawn your preferred photo application
+and import the new pictures from your camera.")
+ (license gpl2+)))