summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:24:02 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:18:43 +0800
commit7fc3d5f3ec030ef7c85b7f140aabafc2de0f2f6d (patch)
tree7c60fe5df4b030e75aad7a41be51064b92af4902 /gnu
parent2eb7d77d48a6fb452021d456fe18d5acd24ba9ec (diff)
downloadguix-patches-7fc3d5f3ec030ef7c85b7f140aabafc2de0f2f6d.tar
guix-patches-7fc3d5f3ec030ef7c85b7f140aabafc2de0f2f6d.tar.gz
gnu: Add garcon.
* gnu/packages/xfce.scm (garcon): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bd2770dab9..4d061b06be 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -166,3 +166,30 @@ that are targeted at desktop development, libexo is targeted at application
development.")
;; Libraries are under LGPLv2+, and programs under GPLv2+.
(license (list gpl2+ lgpl2.1+))))
+
+(define-public garcon
+ (package
+ (name "garcon")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0v7pkvxcayi86z4f173z5l7w270f3g369sa88z59w0y0p7ns7ph2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("glib:bin" ,glib "bin")))
+ (propagated-inputs `(("glib" ,glib))) ; required by garcon-1.pc
+ (inputs `(("libxfce4util" ,libxfce4util)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Implementation of the freedesktop.org menu specification")
+ (description
+ "Garcon is a freedesktop.org compliant menu implementation based on
+GLib and GIO. It was started as a complete rewrite of the former Xfce menu
+library called libxfce4menu, which, in contrast to garcon, was lacking menu
+merging features essential for loading menus modified with menu editors.")
+ (license lgpl2.0+)))