summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-04 20:57:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-04 22:09:03 +0200
commit5ab51bee586505d6e48fca584c7e084047f920b3 (patch)
tree3a60f8638d2b26e39d276d2f5b50ce7f44f015ae /gnu
parentc64a78cec17af028b08cc5f60daa68a9e2ea652d (diff)
downloadguix-patches-5ab51bee586505d6e48fca584c7e084047f920b3.tar
guix-patches-5ab51bee586505d6e48fca584c7e084047f920b3.tar.gz
gnu: interception-tools: Update to 0.6.7.
* gnu/packages/linux.scm (interception-tools): Update to 0.6.7. [arguments]: Remove obsolete 'fix-libevdev-path phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 99134bdb4e..e2e30f5de5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3741,7 +3741,7 @@ devices that can inject events directly into the input subsystem.")
(define-public interception-tools
(package
(name "interception-tools")
- (version "0.6.6")
+ (version "0.6.7")
(home-page "https://gitlab.com/interception/linux/tools")
(source (origin
(method git-fetch)
@@ -3751,25 +3751,17 @@ devices that can inject events directly into the input subsystem.")
(file-name (git-file-name name version))
(sha256
(base32
- "0k9h14a9d65nwvv7pj0kigjgzfv453mm3r4svnxfg1h5lccmy8jj"))))
+ "0wcmppa7092b33wb8vc782day5phf90pc25cn1x7rk0rlw565z36"))))
(build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("boost" ,boost)
("libevdev" ,libevdev)
("libudev" ,eudev)
("yaml-cpp" ,yaml-cpp)))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-libevdev-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libevdev (assoc-ref inputs "libevdev")))
- (substitute* "CMakeLists.txt"
- (("/usr/include/libevdev-1.0")
- (string-append libevdev "/include/libevdev-1.0")))
- #t))))
- ;; No tests are included.
- #:tests? #f))
+ `(#:tests? #f)) ; no test suite
(synopsis "Utilities for operating on input events of evdev devices")
(description
"Interception Tools provides a composable infrastructure on top of