summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-14 00:38:06 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-15 18:51:30 +0800
commit5a659a489ef8ffe708f4e24c65cf6ae5200e059a (patch)
treefa456e475e12df1dbcdc576539c6ae9ebc0ac880 /gnu
parent5afbfb992486a848c7af4a41e5a02b012483a819 (diff)
downloadguix-patches-5a659a489ef8ffe708f4e24c65cf6ae5200e059a.tar
guix-patches-5a659a489ef8ffe708f4e24c65cf6ae5200e059a.tar.gz
gnu: Add vala.
* gnu/packages/gnome.scm (vala): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1d3ce25421..5d84f4e411 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1292,3 +1292,35 @@ engineering.")
(description
"The default GNOME 3 themes (Adwaita and some accessibility themes).")
(license license:lgpl2.1+)))
+
+(define-public vala
+ (package
+ (name "vala")
+ (version "0.26.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0swyym2papln0f62ah05dpvq3vv6fssap26jq2zqp9dkkaqsn1w4"))))
+ (build-system gnu-build-system)
+ (arguments '(#:make-flags '("CC=gcc")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("flex" ,flex)
+ ("bison" ,bison)
+ ("xsltproc" ,libxslt)
+ ("dbus" ,dbus) ; for dbus tests
+ ("gobject-introspection" ,gobject-introspection))) ; for gir tests
+ (propagated-inputs
+ `(("glib" ,glib))) ; required by libvala-0.26.pc
+ (home-page "http://live.gnome.org/Vala/")
+ (synopsis "Compiler for the GObject type system")
+ (description
+ "Vala is a programming language that aims to bring modern programming
+language features to GNOME developers without imposing any additional runtime
+requirements and without using a different ABI compared to applications and
+libraries written in C.")
+ (license license:lgpl2.1+)))