summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:23:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:21 +0200
commit478a889925a488ea2785c4146b0da8c63d79209b (patch)
treee6378bfb3e915934e8da05abb5e16826c3f42e0d /gnu
parent16cc95c4e9369dc95b2b05a9441402dc12b98e9d (diff)
downloadguix-patches-478a889925a488ea2785c4146b0da8c63d79209b.tar
guix-patches-478a889925a488ea2785c4146b0da8c63d79209b.tar.gz
gnu: Add r-paws-networking.
* gnu/packages/cran.scm (r-paws-networking): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 56e20a0c9c..fb93f1585e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30790,3 +30790,27 @@ natural language processing, speech recognition, translation, and more.")
governance services, including CloudWatch application and infrastructure
monitoring, Auto Scaling for automatically scaling resources, and more.")
(license license:asl2.0)))
+
+(define-public r-paws-networking
+ (package
+ (name "r-paws-networking")
+ (version "0.1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "paws.networking" version))
+ (sha256
+ (base32
+ "02hxaa5nlj70mdggh379ij3fn09xm8h5ldzsyf45c342prpl6zwj"))))
+ (properties
+ `((upstream-name . "paws.networking")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-paws-common" ,r-paws-common)))
+ (home-page "https://github.com/paws-r/paws")
+ (synopsis "Amazon Web Services networking and content delivery services")
+ (description
+ "This package provides an interface to Amazon Web Services networking and
+content delivery services, including Route 53 Domain Name System service,
+CloudFront content delivery, load balancing, and more.")
+ (license license:asl2.0)))