summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-22 22:52:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-23 18:17:17 +0200
commit2b260efbfc035d4ce33f1ab6094f938e11c2c91d (patch)
tree3696d827fb13613f2cc9426fe248e98bd181743d /gnu
parentbea4a3abec0d039274547e5284fbfc5276bd87f4 (diff)
downloadguix-patches-2b260efbfc035d4ce33f1ab6094f938e11c2c91d.tar
guix-patches-2b260efbfc035d4ce33f1ab6094f938e11c2c91d.tar.gz
gnu: Add xfsprogs-static.
* gnu/packages/linux.scm (xfsprogs/static): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b3354d1100..08a3995c9c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7731,6 +7731,31 @@ file systems.")
;; licensed under lgpl2.1. the other stuff is licensed under gpl2.
(license (list license:gpl2 license:lgpl2.1))))
+(define-public xfsprogs/static
+ (package
+ (inherit xfsprogs)
+ (name "xfsprogs-static")
+ (outputs (list "out"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments xfsprogs)
+ ((#:make-flags make-flags ''())
+ `(cons* "LLDFLAGS=-all-static" ,make-flags))
+ ((#:phases _ ''())
+ `(modify-phases %standard-phases
+ (add-after 'install 'delete-useless-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion (assoc-ref outputs "out")
+ (for-each delete-file-recursively
+ (list "include" "lib")))))))))
+ (inputs
+ `(("libinih:static" ,libinih "static")
+ ("util-linux:static" ,util-linux "static")
+ ,@(remove (match-lambda
+ ((label . _)
+ (member label '("python"))))
+ (package-inputs xfsprogs))))
+ (synopsis "Statically linked XFS file system tools")))
+
(define-public genext2fs
(package
(name "genext2fs")