summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:24:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:22 +0200
commitb28a60c02c26e815e3e648d62df23db1773cbba6 (patch)
tree60e27490cb34c8c4fc1a6febb58aa833f0c67112 /gnu
parent738a48adb1c5c7e69e37105713fdd28706bafd73 (diff)
downloadguix-patches-b28a60c02c26e815e3e648d62df23db1773cbba6.tar
guix-patches-b28a60c02c26e815e3e648d62df23db1773cbba6.tar.gz
gnu: Add r-filehash.
* gnu/packages/cran.scm (r-filehash): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 32f3774da6..890bf645b6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31001,3 +31001,28 @@ archaeological contexts. The zoolog package is also able to seamlessly
integrate data and references with heterogeneous nomenclature, which is
internally managed by a zoolog thesaurus.")
(license license:gpl3)))
+
+(define-public r-filehash
+ (package
+ (name "r-filehash")
+ (version "2.4-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "filehash" version))
+ (sha256
+ (base32
+ "14zv7h5195dmfksgk8qvjgc2qq8253vga6267aa1bqs5bpvmdl5n"))))
+ (properties `((upstream-name . "filehash")))
+ (build-system r-build-system)
+ (home-page "http://github.com/rdpeng/filehash")
+ (synopsis "Simple key-value database")
+ (description
+ "This package implements a simple key-value style database where
+character string keys are associated with data values that are stored on the
+disk. A simple interface is provided for inserting, retrieving, and deleting
+data from the database. Utilities are provided that allow filehash databases
+to be treated much like environments and lists are already used in R. These
+utilities are provided to encourage interactive and exploratory analysis on
+large datasets.")
+ (license license:gpl2+)))