summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-20 23:47:22 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-20 23:47:22 +0200
commit4db00e42109b6f8229259859deac35499eec9004 (patch)
tree7bec555f6813e5327f6d6268b3f654abdcd4cd0d /gnu
parentfba96c4885aa5b95c42120387db0450d9794508a (diff)
downloadguix-patches-4db00e42109b6f8229259859deac35499eec9004.tar
guix-patches-4db00e42109b6f8229259859deac35499eec9004.tar.gz
gnu: libgc: Always build with -DUSE_LIBC_PRIVATES.
* gnu/packages/bdw-gc.scm (libgc): Add `arguments' field. * gnu/packages/make-bootstrap.scm (%guile-static): Remove local `libgc'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bdw-gc.scm5
-rw-r--r--gnu/packages/make-bootstrap.scm8
2 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index ad0577b1ea..bebb0862e3 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -35,7 +35,10 @@
(base32
"0phwa5driahnpn79zqff14w9yc8sn3599cxz91m78hqdcpl0mznr"))))
(build-system gnu-build-system)
- ;; TODO: Build with -DUSE_LIBC_PRIVATES (see make-bootstrap.scm).
+ (arguments
+ ;; Make it so that we don't rely on /proc. This is especially useful in
+ ;; an initrd run before /proc is mounted.
+ '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES")))
(synopsis "The Boehm-Demers-Weiser conservative garbage collector
for C and C++")
(description
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index de4e0dcbeb..b927d5db25 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -404,13 +404,7 @@
;; A statically-linked Guile that is relocatable--i.e., it can search
;; .scm and .go files relative to its installation directory, rather
;; than in hard-coded configure-time paths.
- (let* ((libgc (package (inherit libgc)
- (arguments
- ;; Make it so that we don't rely on /proc. This is
- ;; especially useful in an initrd run before /proc is
- ;; mounted.
- '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES")))))
- (guile (package (inherit guile-2.0)
+ (let* ((guile (package (inherit guile-2.0)
(name (string-append (package-name guile-2.0) "-static"))
(inputs
`(("patch/relocatable"