summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:29 +0200
commit4638c52e32f15610a65c3dfc5e6833be088646b9 (patch)
tree56d8e85d2f0a61940796507202e5b7f47d23ebe2 /gnu
parent3d111f14302e99dd4bcd1d8d60fdde312cd027c0 (diff)
downloadguix-patches-4638c52e32f15610a65c3dfc5e6833be088646b9.tar
guix-patches-4638c52e32f15610a65c3dfc5e6833be088646b9.tar.gz
gnu: Add r-zonator.
* gnu/packages/cran.scm (r-zonator): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 98ed932014..a8164c8a98 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31143,3 +31143,30 @@ motivated by research into the merits of different zoning systems. A flexible
@code{ClockBoard} zoning system is provided, which breaks-up space by
concentric rings and radial lines emanating from a central point.")
(license license:gpl3)))
+
+(define-public r-zonator
+ (package
+ (name "r-zonator")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "zonator" version))
+ (sha256
+ (base32
+ "1plxchpd4ypp36phl13pi9yvlrqi3lk83lv5rldrhdqynhcgfw2k"))))
+ (properties `((upstream-name . "zonator")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-raster" ,r-raster)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rgdal" ,r-rgdal)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://cbig.github.io/zonator/")
+ (synopsis "Utilities for Zonation spatial conservation prioritization")
+ (description
+ "Create new analysis setups and deal with results of Zonation
+conservation prioritization software.")
+ (license license:bsd-2)))