summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-17 11:40:34 -0400
committerMark H Weaver <mhw@netris.org>2015-04-17 11:40:34 -0400
commitdb5127d889d29895c9bb72337598001f7f8bdb53 (patch)
tree3a86a46a67b4aecac68154774136084aed7cd93e /gnu
parent933204e5b1473a54367aef1f90de22424e9074ab (diff)
downloadguix-patches-db5127d889d29895c9bb72337598001f7f8bdb53.tar
guix-patches-db5127d889d29895c9bb72337598001f7f8bdb53.tar.gz
gnu: gnome-vfs: Tolerate 'test-async-cancel' failures, take two.
* gnu/packages/gnome.scm (gnome-vfs)[arguments]: Remove 'XFAIL_TESTS' make flag, which caused 'make check' to fail if the test unexpectedly passed. Add 'patch-test-async-cancel-to-never-fail' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 487dd8dcd2..f508ba9cbb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -884,10 +884,7 @@ designed to be accessed through the MIME functions in GnomeVFS.")
"1ajg8jb8k3snxc7rrgczlh8daxkjidmcv3zr9w809sq4p2sn9pk2"))))
(build-system gnu-build-system)
(arguments
- `(;; XXX The 'test-async-cancel' test often fails.
- #:make-flags '("XFAIL_TESTS=test-async-cancel")
-
- #:phases
+ `(#:phases
(alist-cons-before
'configure 'ignore-deprecations
(lambda _
@@ -895,7 +892,12 @@ designed to be accessed through the MIME functions in GnomeVFS.")
"daemon/Makefile.in")
(("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS"))
#t)
- %standard-phases)))
+ (alist-cons-before
+ 'configure 'patch-test-async-cancel-to-never-fail
+ (lambda _
+ (substitute* "test/test-async-cancel.c"
+ (("EXIT_FAILURE") "77")))
+ %standard-phases))))
(inputs `(("glib" ,glib)
("libxml2" ,libxml2)
("dbus-glib" ,dbus-glib)