summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-08 11:24:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-08 14:03:56 +0200
commit7fd30d1be43ac96e69e9b291b8d7790db7ce8ec6 (patch)
tree178fd39ab90ac0bb4f788f4ddb700dbc21c508b1 /gnu
parent9602e3cce95264d563804d372f44a0d88bad3e9f (diff)
downloadguix-patches-7fd30d1be43ac96e69e9b291b8d7790db7ce8ec6.tar
guix-patches-7fd30d1be43ac96e69e9b291b8d7790db7ce8ec6.tar.gz
gnu: yoshimi: Update to 1.4.1.
* gnu/packages/music.scm (yoshimi): Update to 1.4.1. [arguments]: Add build phase "find-ncurses".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cbe81ccf72..f7b1b17cd7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1457,7 +1457,7 @@ capabilities, custom envelopes, effects, etc.")
(define-public yoshimi
(package
(name "yoshimi")
- (version "1.3.8.2")
+ (version "1.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/yoshimi/"
@@ -1465,7 +1465,7 @@ capabilities, custom envelopes, effects, etc.")
"/yoshimi-" version ".tar.bz2"))
(sha256
(base32
- "0wl4ln6v1nkkx56kfah23chyrhga2vi93i82g0s200c4s4184xr8"))))
+ "133sx42wb66g803pcrgdwph40wh94knvab3yfqkgm0001jv4v14y"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -1485,7 +1485,17 @@ capabilities, custom envelopes, effects, etc.")
(("-msse -msse2 -mfpmath=sse") "")
(("-march=(athlon64|core2)" flag)
(string-append flag " -msse -msse2 -mfpmath=sse")))
- #t)))))
+ #t))
+ ;; Yoshimi tries to find ncurses with pkg-config, but our ncurses
+ ;; package does not install .pc files.
+ (add-after 'unpack 'find-ncurses
+ (lambda _
+ (substitute* "src/CMakeLists.txt"
+ (("LIBNCURSES REQUIRED") "LIBNCURSES")
+ (("NCURSES REQUIRED") "NCURSES")
+ (("FATAL_ERROR \"libncurses") "STATUS \"libncurses")
+ (("\\$\\{NCURSES_LIBRARIES\\}") "ncurses"))
+ #t)))))
(inputs
`(("boost" ,boost)
("fftwf" ,fftwf)