summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-07 15:27:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-07 23:32:41 +0100
commit3af149f524122a9f8a4802208777fe26b369f60c (patch)
treec257c91e621fc94371e94dfd44a5b02fd43ab3ba /gnu
parent902fb15d92da67fd3b4879b4ed73a7ae1879569e (diff)
downloadguix-patches-3af149f524122a9f8a4802208777fe26b369f60c.tar
guix-patches-3af149f524122a9f8a4802208777fe26b369f60c.tar.gz
gnu: Add r-complexheatmap.
* gnu/packages/bioinformatics.scm (r-complexheatmap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8b90c3bff0..cd28798a03 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9516,6 +9516,36 @@ distributed by file or by range. User defined mapper and reducer functions
provide added flexibility for data combination and manipulation.")
(license license:artistic2.0)))
+(define-public r-complexheatmap
+ (package
+ (name "r-complexheatmap")
+ (version "1.17.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ComplexHeatmap" version))
+ (sha256
+ (base32
+ "1x6kp55iqqsd8bhdl3qch95nfiy2y46ldbbsx1sj1v8f0b0ywwcy"))))
+ (properties
+ `((upstream-name . "ComplexHeatmap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-circlize" ,r-circlize)
+ ("r-colorspace" ,r-colorspace)
+ ("r-getoptlong" ,r-getoptlong)
+ ("r-globaloptions" ,r-globaloptions)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page
+ "https://github.com/jokergoo/ComplexHeatmap")
+ (synopsis "Making Complex Heatmaps")
+ (description
+ "Complex heatmaps are efficient to visualize associations between
+different sources of data sets and reveal potential structures. This package
+provides a highly flexible way to arrange multiple heatmaps and supports
+self-defined annotation graphics.")
+ (license license:gpl2+)))
+
(define-public r-qvalue
(package
(name "r-qvalue")