summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-07-07 14:41:41 -0500
committerEric Bavier <bavier@member.fsf.org>2016-07-20 18:31:16 -0500
commitd721c83a6310bcb2ded092e20afb3954b21038fb (patch)
treecd903d936a855cbeef3563e965ef8ff4421900f2 /gnu
parentb006ba50384f9cb517fa881299160adba0aaca9e (diff)
downloadguix-patches-d721c83a6310bcb2ded092e20afb3954b21038fb.tar
guix-patches-d721c83a6310bcb2ded092e20afb3954b21038fb.tar.gz
gnu: Add libhilbert.
* gnu/packages/maths.scm (libhilbert): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b8ec213d8b..03f874e057 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2538,3 +2538,25 @@ structured and unstructured grid problems.")))
(description "Matio is a library for reading and writing MAT files. It
supports compressed MAT files, as well as newer (version 7.3) MAT files.")
(license license:bsd-2)))
+
+(define-public libhilbert
+ (package
+ (name "libhilbert")
+ (version "0.2-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://web.cs.dal.ca/~chamilto/hilbert/"
+ "libhilbert-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0v48x8405dj95gjn2saja4bzhw86d6zl6d3dg8h7dzac2qr97s34"))))
+ (build-system gnu-build-system)
+ (home-page "http://web.cs.dal.ca/~chamilto/hilbert")
+ (synopsis "Hilbert indices for multidimensional data")
+ (description "The libhilbert library can efficiently calculate Hilbert
+curves and order-preserving representations of Hilbert curve indices that use
+the same amount of space as the original point representation. This is useful
+when using the Gilbert curve as a space filling curve through a
+high-dimensional space where not all demensions have the same cardinality.")
+ (license license:lgpl2.1+)))