summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public01@thebird.nl>2017-03-07 10:28:57 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-07 18:19:51 +0100
commitd6abd094fcffdbd5b693ba509e2de3da28c849ec (patch)
tree6cba2a53336b65d24760cd0d8d50d6efdd47c6b1 /gnu
parent92966847130557ee99029d89b715a1701e5b04df (diff)
downloadguix-patches-d6abd094fcffdbd5b693ba509e2de3da28c849ec.tar
guix-patches-d6abd094fcffdbd5b693ba509e2de3da28c849ec.tar.gz
gnu: python-rpy2: Propagate python2-singledispatch.
* gnu/packages/python.scm (python-rp2)[native-inputs]: Rename to... [propagated-inputs]: ... this. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a271ad46b7..1ce0cc47e3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4093,9 +4093,9 @@ functions.")
(define-public python2-rpy2
(let ((rpy2 (package-with-python2 python-rpy2)))
(package (inherit rpy2)
- (native-inputs
+ (propagated-inputs
`(("python2-singledispatch" ,python2-singledispatch)
- ,@(package-native-inputs rpy2))))))
+ ,@(package-propagated-inputs rpy2))))))
(define-public python-scipy
(package