summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-10 14:51:04 -0400
committerMark H Weaver <mhw@netris.org>2015-07-11 19:06:20 -0400
commitaa7251176f273d64ec54f71e305d813092bf4c7f (patch)
tree9e1fb6b989f71a5d853aeafb2e53b88ccfcb45b7 /gnu
parent16f71908308106d098fa44104e177e328c593359 (diff)
downloadguix-patches-aa7251176f273d64ec54f71e305d813092bf4c7f.tar
guix-patches-aa7251176f273d64ec54f71e305d813092bf4c7f.tar.gz
gnu: Require NEON on armhf.
* gnu/packages/gcc.scm (gcc-configure-flags-for-triplet): On armhf, include --with-fpu=neon. * doc/guix.texi (GNU Distribution): Document that our armhf port requires NEON.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 23bfd90b33..8b88dff4dc 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -55,9 +55,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
'("--with-arch=armv7-a"
"--with-float=hard"
"--with-mode=thumb"
-
- ;; See <https://wiki.debian.org/ArmHardFloatPort/VfpComparison#FPU>
- "--with-fpu=vfpv3-d16"))
+ "--with-fpu=neon"))
(else
;; TODO: Add `arm.*-gnueabi', etc.