summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-11 23:15:11 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-11 23:16:37 +0200
commit895067ff495a35768e1ba39e969eff3495b8cbc4 (patch)
treed823a0b7c599dd8b62c05786724fdfbbb17254b5 /gnu
parentb86c013c68be640521b533e1dd40115e2cb72b40 (diff)
downloadguix-patches-895067ff495a35768e1ba39e969eff3495b8cbc4.tar
guix-patches-895067ff495a35768e1ba39e969eff3495b8cbc4.tar.gz
gnu: coreutils: Skip racy 'tail' tests.
This works around <http://bugs.gnu.org/21460>. * gnu/packages/patches/coreutils-racy-tail-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (coreutils): Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm4
-rw-r--r--gnu/packages/patches/coreutils-racy-tail-test.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e2d4727c9c..f60a6cfeef 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -248,7 +248,9 @@ used to apply commands with arbitrarily long arguments.")
version ".tar.xz"))
(sha256
(base32
- "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))))
+ "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))
+ (patches
+ (list (search-patch "coreutils-racy-tail-test.patch")))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp) ;bignums in 'expr', yay!
diff --git a/gnu/packages/patches/coreutils-racy-tail-test.patch b/gnu/packages/patches/coreutils-racy-tail-test.patch
new file mode 100644
index 0000000000..91640513e4
--- /dev/null
+++ b/gnu/packages/patches/coreutils-racy-tail-test.patch
@@ -0,0 +1,13 @@
+Skip this test, which uncovers a race condition in how 'tail' handles
+file deletion. See <http://bugs.gnu.org/21460>.
+
+--- a/tests/tail-2/assert.sh
++++ b/tests/tail-2/assert.sh
+@@ -16,6 +16,7 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
++exit 77 # see <http://bugs.gnu.org/21460>
+
+ # This test fails with tail from textutils-2.0.
+ # It would get something like this: