summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-07-08 12:15:01 -0500
committerEric Bavier <bavier@member.fsf.org>2016-07-20 21:16:25 -0500
commit8787c555d9552a13be4917c4f4a0e37b61ab7b5e (patch)
tree6ba724b555b889b35b5a318b22e116515f7d319a /gnu
parentfafd623e4901873698a227f4f7980d5022b1b6e2 (diff)
downloadguix-patches-8787c555d9552a13be4917c4f4a0e37b61ab7b5e.tar
guix-patches-8787c555d9552a13be4917c4f4a0e37b61ab7b5e.tar.gz
gnu: slepc: Update to 3.7.1.
* gnu/packages/maths.scm (slepc): Update to 3.7.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7744f44a0f..464cf8d412 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -923,7 +923,7 @@ scientific applications modeled by partial differential equations.")
(define-public slepc
(package
(name "slepc")
- (version "3.6.2")
+ (version "3.7.1")
(source
(origin
(method url-fetch)
@@ -932,7 +932,7 @@ scientific applications modeled by partial differential equations.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1pv5iqz2kc8sj49zsabyz4arnfpana8mjrhq31vzgk16xldk3d1a"))))
+ "1hijlmrvxvfqslnx8yydzw5xqbsn1yy02g32w0hln1z3cgr1c0k7"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2)))
@@ -948,8 +948,7 @@ scientific applications modeled by partial differential equations.")
(assoc-ref %build-inputs "arpack") "/lib"))
#:phases
(modify-phases %standard-phases
- (replace
- 'configure
+ (replace 'configure
;; configure is a python script, so we can't run it with bash.
(lambda* (#:key inputs outputs (configure-flags '())
#:allow-other-keys)
@@ -961,8 +960,7 @@ scientific applications modeled by partial differential equations.")
(setenv "SLEPC_DIR" (getcwd))
(setenv "PETSC_DIR" (assoc-ref inputs "petsc"))
(zero? (apply system* "./configure" flags)))))
- (add-after
- 'install 'delete-doc
+ (add-after 'install 'delete-doc
;; TODO: SLEPc installs HTML documentation alongside headers in
;; $out/include. We'd like to move them to share/doc, but delete
;; them for now, as they are incomplete and installing the complete
@@ -970,8 +968,7 @@ scientific applications modeled by partial differential equations.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(for-each delete-file (find-files out "\\.html$")))))
- (add-after
- 'install 'clean-install
+ (add-after 'install 'clean-install
;; Clean up unnecessary build logs from installation.
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))