summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-02-09 00:25:51 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-03-17 23:15:57 -0400
commitc0d43f62232507b441edf28c3f051921dfb04c2a (patch)
tree03ceb59d1e8e319b9e1ee270209adbb99b8be23d /gnu
parent667c6ef51606ab39a8e8d849d3dcd09f8ee36e00 (diff)
downloadguix-patches-c0d43f62232507b441edf28c3f051921dfb04c2a.tar
guix-patches-c0d43f62232507b441edf28c3f051921dfb04c2a.tar.gz
gnu: python-pandas: Update to 0.24.2.
* gnu/packages/python-xyz.scm (python-pandas): Update to 0.24.2. [phases]{patch-which}: Add phase. [inputs]: Add WHICH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a1e7bc8831..ed54f54593 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1011,13 +1011,13 @@ human-friendly syntax.")
(define-public python-pandas
(package
(name "python-pandas")
- (version "0.23.4")
+ (version "0.24.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pandas" version))
(sha256
- (base32 "1x54pd7hr3y7qahx6b5bf2wzj54xvl8r3s1h4pl254pnmi3wl92v"))))
+ (base32 "18imlm8xbhcbwy4wa957a1fkamrcb0z988z006jpfda3ki09z4ag"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -1025,6 +1025,13 @@ human-friendly syntax.")
(ice-9 ftw)
(srfi srfi-26))
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-which
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((which (assoc-ref inputs "which")))
+ (substitute* "pandas/io/clipboard/__init__.py"
+ (("^CHECK_CMD = .*")
+ (string-append "CHECK_CMD = \"" which "\"\n"))))
+ #t))
(replace 'check
(lambda _
(let ((build-directory
@@ -1033,12 +1040,13 @@ human-friendly syntax.")
(car (scandir "build"
(cut string-prefix? "lib." <>))))))
;; Disable the "strict data files" option which causes
- ;; the build to error out if required data files are not
- ;; available (as is the case with PyPI archives).
+ ;; the build to error out if required data files are
+ ;; not available (as is the case with PyPI archives).
(substitute* "setup.cfg"
(("addopts = --strict-data-files") "addopts = "))
(with-directory-excursion build-directory
- ;; Delete tests that require "moto" which is not yet in Guix.
+ ;; Delete tests that require "moto" which is not yet
+ ;; in Guix.
(for-each delete-file
'("pandas/tests/io/conftest.py"
"pandas/tests/io/json/test_compression.py"
@@ -1054,13 +1062,16 @@ human-friendly syntax.")
("python-pytz" ,python-pytz)
("python-dateutil" ,python-dateutil)
("python-xlrd" ,python-xlrd)))
+ (inputs
+ `(("which" ,which)))
(native-inputs
`(("python-cython" ,python-cython)
("python-beautifulsoup4" ,python-beautifulsoup4)
("python-lxml" ,python-lxml)
("python-html5lib" ,python-html5lib)
("python-nose" ,python-nose)
- ("python-pytest" ,python-pytest)))
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-mock" ,python-pytest-mock)))
(home-page "https://pandas.pydata.org")
(synopsis "Data structures for data analysis, time series, and statistics")
(description