summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-15 12:02:55 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-15 12:05:10 +0200
commit4f9ff21ea0c5ddb29a368ef78b6b8493a01d1d74 (patch)
treedb6c0f20527e6262e65d7723ceab1e8f8bddfc9f /gnu
parent5248d49e412274c3fb92a8e5d5ea8e098b1704b6 (diff)
downloadguix-patches-4f9ff21ea0c5ddb29a368ef78b6b8493a01d1d74.tar
guix-patches-4f9ff21ea0c5ddb29a368ef78b6b8493a01d1d74.tar.gz
gnu: python-scipy: Add phase to fix tests.
* gnu/packages/python.scm (python-scipy)[arguments]: Add build phase "fix-tests".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 58ae9c7b40..3319938ec6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3330,7 +3330,13 @@ atlas_libs = openblas
(zero? (system* "python" "-c" "import scipy; scipy.test()"))))
(alist-delete
'check
- %standard-phases))))))
+ (alist-cons-after
+ 'unpack 'fix-tests
+ (lambda _
+ (substitute* "scipy/integrate/tests/test_quadpack.py"
+ (("libm.so") "libm.so.6"))
+ #t)
+ %standard-phases)))))))
(home-page "http://www.scipy.org/")
(synopsis "The Scipy library provides efficient numerical routines")
(description "The SciPy library is one of the core packages that make up