summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-04 23:43:45 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-05 09:24:34 +0000
commitfd9a6d83c280593bd61805a78a9f45ced3e6a527 (patch)
treea2faf3109788b284cea2f95cf3e9c89780ab568a /gnu
parent16bb27f281298afcf7f7c2fb9200adf5d79c9e6c (diff)
downloadguix-patches-fd9a6d83c280593bd61805a78a9f45ced3e6a527.tar
guix-patches-fd9a6d83c280593bd61805a78a9f45ced3e6a527.tar.gz
gnu: artanis: Make some improvements.
* gnu/packages/guile-xyz.scm (artanis): Remove a tab character by the revision. [arguments]: Patch the site-dir for the help command, to make it work. Wrap the art command such that it finds guile-json and guile-redis.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9640d17c3c..6c1e9c50ec 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -85,7 +85,7 @@
(define-public artanis
(let ((release "0.3.1")
- (revision 0))
+ (revision 0))
(package
(name "artanis")
(version (if (zero? revision)
@@ -152,6 +152,13 @@
#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-site-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "artanis/commands/help.scm"
+ (("\\(%site-dir\\)")
+ (string-append "\""
+ (assoc-ref outputs "out")
+ "/share/guile/site/2.2\"")))))
(add-before 'install 'substitute-root-dir
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -162,14 +169,16 @@
(mkdir-p (string-append out "/bin")) ;for the `art' executable
#t)))
(add-after 'install 'wrap-art
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(scm (string-append out "/share/guile/site/2.2"))
(go (string-append out "/lib/guile/2.2/site-ccache")))
(wrap-program (string-append bin "/art")
- `("GUILE_LOAD_PATH" ":" prefix (,scm))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,go)))
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,scm ,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,go ,(getenv "GUILE_LOAD_COMPILED_PATH"))))
#t))))))
(synopsis "Web application framework written in Guile")
(description "GNU Artanis is a web application framework written in Guile