summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 23:06:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 23:06:57 +0100
commitf96eda90d5b015057dfd28d4ef7466dbae4bc3f5 (patch)
tree08595589c6508b932741a9cce784e54c9f133eb6 /gnu
parent7531ee842c19c481b3e4785b36cf6558b054e6b2 (diff)
downloadguix-patches-f96eda90d5b015057dfd28d4ef7466dbae4bc3f5.tar
guix-patches-f96eda90d5b015057dfd28d4ef7466dbae4bc3f5.tar.gz
gnu: Add r-expm.
* gnu/packages/cran.scm (r-expm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ce676334c6..e7efab78ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2624,3 +2624,24 @@ Homogeinity Test), detection of non-randomness (Wallis-Moore Phase Frequency
Test, Bartels rank von Neumann's ratio test, Wald-Wolfowitz Test) and the two
sample Robust Rank-Order Distributional Test.")
(license license:gpl3)))
+
+(define-public r-expm
+ (package
+ (name "r-expm")
+ (version "0.999-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "expm" version))
+ (sha256
+ (base32
+ "1mihl67kvv1xv0figp25jkmwfn4iwkcx15cng2348y8gm6zybw9q"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-matrix" ,r-matrix)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "http://r-forge.r-project.org/projects/expm/")
+ (synopsis "Tools for matrix exponentials and related quantities")
+ (description
+ "This package provides tools for the computation of the matrix
+exponential, logarithm, square root, and related quantities.")
+ (license license:gpl2+)))