summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 01:05:53 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:21 +0300
commitf63b2dd7db358eb23f9bca6edf90193266d72e7f (patch)
treeee6b19a216125fea3284aa27e23c87acf3bc0c1b /gnu
parent55374b806cbebb0ada67249dc5aaa67849350832 (diff)
downloadguix-patches-f63b2dd7db358eb23f9bca6edf90193266d72e7f.tar
guix-patches-f63b2dd7db358eb23f9bca6edf90193266d72e7f.tar.gz
gnu: Add go-github-com-olekukonko-tablewriter.
* gnu/packages/golang.scm (go-github-com-olekukonko-tablewriter): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5d2d4cd7ea..48a3ed97d4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4917,3 +4917,43 @@ its ANSI and color support and offers you convenient methods to colorize and
style your output, without you having to deal with all kinds of weird ANSI
escape sequences and color conversions.")
(license license:expat)))
+
+(define-public go-github-com-olekukonko-tablewriter
+ (package
+ (name "go-github-com-olekukonko-tablewriter")
+ (version "0.0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/olekukonko/tablewriter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02r0n2b9yh3x8xyf48k17dxlwj234hlgjycylbjxi6qg08hfmz2x"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/olekukonko/tablewriter"))
+ (native-inputs
+ `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)))
+ (home-page "https://github.com/olekukonko/tablewriter/")
+ (synopsis "Generate ASCII table")
+ (description "This package allows to generate ASCII table. Features:
+@itemize
+@item automatic Padding
+@item support Multiple Lines
+@item supports Alignment
+@item support Custom Separators
+@item automatic Alignment of numbers and percentage
+@item write directly to http , file etc via @code{io.Writer}
+@item read directly from CSV file
+@item optional row line via @code{SetRowLine}
+@item normalise table header
+@item make CSV Headers optional
+@item enable or disable table border
+@item set custom footer support
+@item optional identical cells merging
+@item set custom caption
+@item optional reflowing of paragrpahs in multi-line cells
+@end itemize\n")
+ (license license:expat)))