summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-01-07 14:15:12 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:45 -0500
commite97e6c05cd1d1aecb8f7bc251d8487ed056bcc81 (patch)
tree8817989df914a5d8288825588236f7b415cec887 /gnu
parent0868479d080e0332f266d8d3453f26fb520daf07 (diff)
downloadguix-patches-e97e6c05cd1d1aecb8f7bc251d8487ed056bcc81.tar
guix-patches-e97e6c05cd1d1aecb8f7bc251d8487ed056bcc81.tar.gz
gnu: python-automat: Remove broken console script.
* gnu/packages/python-xyz.scm (python-automat) [arguments]: Patch setup.py.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0e9ee02265..b5658374da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15073,7 +15073,15 @@ instead of servers and network commands.")
;; python-twisted depends on python-automat. Twisted is optional, but the
;; tests fail if it is not available. Also see
;; <https://github.com/glyph/automat/issues/71>.
- (arguments '(#:tests? #f))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Remove script, because it depends on python-twisted.
+ (add-after 'unpack 'remove-entrypoint
+ (lambda _
+ (substitute* "setup.py"
+ (("\"automat-visualize = automat._visualize:tool\"") "")))))))
(native-inputs
`(("python-m2r" ,python-m2r)
("python-setuptools-scm" ,python-setuptools-scm)