summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-03-01 23:23:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-02 09:41:46 +0100
commitc19544bc4855da7dd6b9b63db275e4e8a88bcd2a (patch)
treea9c156d8fdd506f42222ee20efedc8fa899ddddb /gnu
parent29bcfcd8134bf2868117f88106333164a2c7640b (diff)
downloadguix-patches-c19544bc4855da7dd6b9b63db275e4e8a88bcd2a.tar
guix-patches-c19544bc4855da7dd6b9b63db275e4e8a88bcd2a.tar.gz
gnu: chessx: Update to 1.5.6.
* gnu/packages/games.scm (chessx): Update to 1.5.6. [arguments]: Remove now unneeded build fix. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 14b6868a0e..74d04ad502 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -51,7 +51,7 @@
;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2020, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Lu hux <luhux@outlook.com>
@@ -11794,14 +11794,14 @@ and chess engines.")
(define-public chessx
(package
(name "chessx")
- (version "1.5.4")
+ (version "1.5.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/chessx/chessx/"
version "/chessx-" version ".tgz"))
(sha256
- (base32 "1a3541vl5hp6jllgx998w9kjh9kp3wrl80yfwkxmq1bc5bzsrnz2"))))
+ (base32 "01fjchil2h6ry2ywr0dwjw2g7zd29580cr4c74d5z74h999lp6nh"))))
(build-system qt-build-system)
(native-inputs
`(("qttools" ,qttools)))
@@ -11819,12 +11819,7 @@ and chess engines.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "chessx.pro"
(("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
- (string-append (assoc-ref inputs "qttools") "/bin/lrelease"))
- ;; Fix missing translations.
- (("TRANSLATIONS = i18n/chessx_de.ts")
- "TRANSLATIONS = i18n/chessx_de.ts i18n/chessx_da.ts \\
-i18n/chessx_fr.ts i18n/chessx_it.ts i18n/chessx_cz.ts i18n/chessx_ru.ts \\
-i18n/chessx_es.ts"))
+ (string-append (assoc-ref inputs "qttools") "/bin/lrelease")))
#t))
(add-after 'fix-paths 'make-qt-deterministic
(lambda _