summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-20 14:11:43 -0400
committerMark H Weaver <mhw@netris.org>2015-10-20 14:11:43 -0400
commit7c6fb733e91675d1a0b80e863a422a55d1f3aa5d (patch)
treea81716c171ac75e47eed09c76e2c7de45d5de28f /gnu
parente38a71eea9abaa4e03ef1d7081104f93d26e31b3 (diff)
parentb1599b5299c82230722ec91dbeabcf19e3399c15 (diff)
downloadguix-patches-7c6fb733e91675d1a0b80e863a422a55d1f3aa5d.tar
guix-patches-7c6fb733e91675d1a0b80e863a422a55d1f3aa5d.tar.gz
Merge branch 'master' into dbus-update
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm3
-rw-r--r--gnu/packages/gnunet.scm8
-rw-r--r--gnu/packages/maths.scm4
3 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index b3503e694c..ee94db440a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages doxygen)
#:use-module (gnu packages libffi)
#:use-module (gnu packages acl)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages polkit))
(define-public xdg-utils
@@ -175,6 +176,8 @@ the freedesktop.org XDG Base Directory specification.")
`(("linux-pam" ,linux-pam)
("linux-libre-headers" ,linux-libre-headers)
("libcap" ,libcap)
+ ("dmd" ,dmd) ;for 'halt' and 'reboot', invoked
+ ;when pressing the power button
("dbus" ,dbus)
("eudev" ,eudev)))
(home-page "https://github.com/andywingo/elogind")
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 74cca17bc8..9b273ace7b 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;;
@@ -143,13 +143,13 @@ and support for SSL3 and TLS.")
(define-public gnurl
(package
(name "gnurl")
- (version "7.37.0")
+ (version "7.45.0")
(source (origin
(method url-fetch)
(uri (string-append "https://gnunet.org/sites/default/files/gnurl-"
- version ".tar.gz"))
+ version ".tar.bz2"))
(sha256
- (base32 "1l2q9ih63vkm65zn886kmhqsx906pzx3qjvsxymlmf18kiv18pfd"))))
+ (base32 "0hd8w4wyjwagd4k6vm6srphqbmysz08rcwf8z7f4b2d6d2yrn3mm"))))
(build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls)
("libidn" ,libidn)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6490df5909..5fa37d1535 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -79,13 +79,13 @@
(define-public units
(package
(name "units")
- (version "2.11")
+ (version "2.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/units/units-" version
".tar.gz"))
(sha256 (base32
- "1gjs3wc212aaiq4r76hx9nl1h3fa39n0ljwl9420d6ixl3rdmdjk"))))
+ "1jxvjknz2jhq773jrwx9gc1df3gfy73yqmkjkygqxzpi318yls3q"))))
(build-system gnu-build-system)
(synopsis "Conversion between thousands of scales")
(description