summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-15 18:20:18 +0100
committerMarius Bakke <marius@gnu.org>2021-12-16 22:21:12 +0100
commit745d6cb7d30814ae27da66a845cf0872bfdebbdd (patch)
treec0e9069a906677ce8f3798e9fbabec73aa1fdb7d /gnu
parent48a1bb314dd77916203deadc8ce7bc664e0f95f9 (diff)
downloadguix-patches-745d6cb7d30814ae27da66a845cf0872bfdebbdd.tar
guix-patches-745d6cb7d30814ae27da66a845cf0872bfdebbdd.tar.gz
gnu: ungoogled-chromium: Unexpire accelerated video decoding.
* gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%guix-patches): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/chromium.scm3
-rw-r--r--gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch18
3 files changed, 22 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c5ed210406..afe7c08888 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1847,6 +1847,7 @@ dist_patch_DATA = \
%D%/packages/patches/u-boot-riscv64-fix-extlinux.patch \
%D%/packages/patches/u-boot-rk3399-enable-emmc-phy.patch \
%D%/packages/patches/ucx-tcp-iface-ioctl.patch \
+ %D%/packages/patches/ungoogled-chromium-accelerated-video-decode.patch \
%D%/packages/patches/ungoogled-chromium-extension-search-path.patch \
%D%/packages/patches/ungoogled-chromium-ffmpeg-compat.patch \
%D%/packages/patches/ungoogled-chromium-RUNPATH.patch \
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index a6df47e374..1a9a35e283 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -378,6 +378,9 @@
(search-patch "ungoogled-chromium-RUNPATH.patch")))
(local-file
(assume-valid-file-name
+ (search-patch "ungoogled-chromium-accelerated-video-decode.patch")))
+ (local-file
+ (assume-valid-file-name
(search-patch "ungoogled-chromium-ffmpeg-compat.patch")))
(local-file
(assume-valid-file-name
diff --git a/gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch b/gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch
new file mode 100644
index 0000000000..cbab626e59
--- /dev/null
+++ b/gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch
@@ -0,0 +1,18 @@
+Upstream Chromium no longer supports hardware accelerated video decoding
+on GNU/Linux, yet it still works fine on many systems. This patch "unexpires"
+the support.
+
+Taken from Arch Linux:
+https://github.com/archlinux/svntogit-packages/blob/packages/chromium/trunk/unexpire-accelerated-video-decode-flag.patch
+
+--- a/chrome/browser/flag-metadata.json
++++ b/chrome/browser/flag-metadata.json
+@@ -1285,7 +1285,7 @@
+ {
+ "name": "enable-accelerated-video-decode",
+ "owners": [ "media-dev@chromium.org" ],
+- "expiry_milestone": 93
++ "expiry_milestone": 99
+ },
+ {
+ "name": "enable-accessibility-live-caption",