summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-08-31 09:33:53 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-09-04 15:55:52 +0530
commit743be813418258c8226ad22bd15951fed6fd3724 (patch)
tree210ab30ce8835914671d2d4331bf7ce6da80c10c /gnu
parent36a7af816186eca1927b232dd25c8bd804ba38f9 (diff)
downloadguix-patches-743be813418258c8226ad22bd15951fed6fd3724.tar
guix-patches-743be813418258c8226ad22bd15951fed6fd3724.tar.gz
gnu: emacs-auctex: Configure executable paths.
* gnu/packages/emacs-xyz.scm (emacs-auctex): Configure absolute paths to ghostscript and texlive executables. [inputs]: Add ghostscript.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4d57a9d147..9822784666 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -175,6 +175,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages shells)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages video)
#:use-module (gnu packages haskell-xyz)
@@ -1914,6 +1915,21 @@ as a library for other Emacs packages.")
#:exclude '("^tests/" "^latex/README")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "preview.el"
+ ("preview-gs-command"
+ (string-append (assoc-ref inputs "ghostscript") "/bin/gs")))
+ (substitute* "preview.el"
+ (("\"dvipng ")
+ (string-append "\"" (assoc-ref inputs "texlive")
+ "/bin/dvipng "))
+ (("\"dvips ")
+ (string-append "\"" (assoc-ref inputs "texlive")
+ "/bin/dvips "))
+ (("\"pdf2dsc ")
+ (string-append "\"" (assoc-ref inputs "ghostscript")
+ "/bin/pdf2dsc ")))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1928,7 +1944,8 @@ as a library for other Emacs packages.")
(native-inputs
`(("perl" ,perl)))
(inputs
- `(("texlive" ,(texlive-union (list texlive-amsfonts)))))
+ `(("ghostscript" ,ghostscript)
+ ("texlive" ,(texlive-union (list texlive-amsfonts)))))
(home-page "https://www.gnu.org/software/auctex/")
(synopsis "Integrated environment for TeX")
(description