summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-22 08:59:29 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:46 -0500
commit6f54af26ced9eb12813cf43bdd9df6571f9ca577 (patch)
treee80caecc85be6caea4fdfe0e98ee3af91c9409aa /gnu
parent73068c77f1e1f164b628d8b081011afc844f755e (diff)
downloadguix-patches-6f54af26ced9eb12813cf43bdd9df6571f9ca577.tar
guix-patches-6f54af26ced9eb12813cf43bdd9df6571f9ca577.tar.gz
gnu: python2-virtualenv: Fix build.
* gnu/packages/python-xyz.scm (python2-virtualenv)[arguments]{phases}: Remove argument.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 1 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b6f162cf69..b03fcf0b71 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3188,28 +3188,7 @@ e.g. filters, callbacks and errbacks can all be promises.")
(package
(inherit base)
(arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-after 'set-paths 'adjust-PYTHONPATH
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((python (assoc-ref inputs "python"))
- (python-sitedir (string-append python "/lib/python2.7"
- "/site-packages")))
- ;; XXX: 'python2' always comes first on PYTHONPATH
- ;; and shadows the 'setuptools' input. Move python2
- ;; last: this should be fixed in python-build-system
- ;; in a future rebuild cycle.
- (setenv "PYTHONPATH"
- (string-append (string-join (delete python-sitedir
- (string-split
- (getenv "PYTHONPATH")
- #\:))
- ":")
- ":" python-sitedir))
- (format #t "environment variable `PYTHONPATH' changed to `~a'~%"
- (getenv "PYTHONPATH"))
- #t))))))
+ `(#:python ,python-2))
(propagated-inputs
`(("python-contextlib2" ,python2-contextlib2)
,@(package-propagated-inputs base))))))