summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:50:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:27 +0300
commit63a833759852ef4545f66882594bb3e6a5e52cc6 (patch)
tree317eb577510639436803563b48d99d906bc1ed91 /gnu
parent1fde30c2902808d6c11dd612c1131f0cd24372a3 (diff)
downloadguix-patches-63a833759852ef4545f66882594bb3e6a5e52cc6.tar
guix-patches-63a833759852ef4545f66882594bb3e6a5e52cc6.tar.gz
gnu: Add julia-simpletraits.
* gnu/packages/julia-xyz.scm (julia-simpletraits): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 76cbc1de7c..6bce6353e8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2448,6 +2448,31 @@ formatting an array of n things, e.g. numbers, dates, unitful values. It's used
in @code{Gadfly}, @code{Plots} and @code{Makie} to label axes and keys.")
(license license:expat)))
+(define-public julia-simpletraits
+ (package
+ (name "julia-simpletraits")
+ (version "0.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mauro3/SimpleTraits.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aaq91klwxb0r3ckwihf7rd7jvg70757nkhp5ip4cc3lspnnip23"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-macrotools" ,julia-macrotools)))
+ (home-page "https://github.com/mauro3/SimpleTraits.jl")
+ (synopsis "Simple Traits for Julia")
+ (description "This package provides a macro-based implementation of traits.
+The main idea behind traits is to group types outside the type-hierarchy and to
+make dispatch work with that grouping. The difference to Union-types is that
+types can be added to a trait after the creation of the trait, whereas Union
+types are fixed after creation.")
+ (license license:expat)))
+
(define-public julia-sortingalgorithms
(package
(name "julia-sortingalgorithms")