summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 22:42:27 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:17 +0300
commit4ca2f9d86fb441bd643112c1be1fcd9bea121954 (patch)
tree9d2badef6ba3f270dc046f322b25d18ce765097c /gnu
parent8dd626ee14f108cd7f57babec568455586dbddaf (diff)
downloadguix-patches-4ca2f9d86fb441bd643112c1be1fcd9bea121954.tar
guix-patches-4ca2f9d86fb441bd643112c1be1fcd9bea121954.tar.gz
gnu: Add go-github-com-google-uuid.
* gnu/packages/golang.scm (go-github-com-google-uuid): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fd8bf69322..6589a1d743 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3807,6 +3807,28 @@ are semantically equal in Go (for writing tests).")
(home-page "https://godoc.org/github.com/google/go-cmp/cmp")
(license license:asl2.0)))
+(define-public go-github-com-google-uuid
+ (package
+ (name "go-github-com-google-uuid")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/uuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hfxcf9frkb57k6q0rdkrmnfs78ms21r1qfk9fhlqga2yh5xg8zb"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/uuid"))
+ (home-page "https://github.com/google/uuid/")
+ (synopsis "Generate and inspect UUIDs based on RFC 4122 and DCE 1.1")
+ (description "The uuid package generates and inspects UUIDs based on RFC
+4122 and DCE 1.1: Authentication and Security Services.")
+ (license license:bsd-3)))
+
(define-public go-golang.org-x-sync-errgroup
(let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
(revision "0"))